Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

Image Field Upload - automatisches Thumbnail wird nicht erzeugt

Eingetragen von torfnase (1525)
am 26.06.2015 - 02:32 Uhr in
  • Allgemeines zu Drupal
  • Drupal 7.x oder neuer

Hallo Drupal Experten,
folgendes Problem habe ich gerade:

Ich habe einen Inhaltstyp, z.B. page und dieser hat ein Image-Field, man kann also zu einem Beitrag ein Bild hochladen.

Normalerweise sollte dazu auch immer gleich automatisch ein Thumbnail erstellt werden, so habe ich es eingestellt.
Das funktioniert auch auf einem Server, auf einem anderen Server funktioniert es aber nicht.

Das Modul Imageinfo Cache habe ich schon mal ausprobiert, der Sachverhalt blieb aber unverändert.
Es gibt keinerlei Fehlermeldungen wegen einer Schreibberechtigung, das Bild ist eine öffentliche Datei.

Weiß jemand von euch, ob das an einer PHP-Variablen liegt, die man vielleicht umstellen/anpassen muß.

Gruß
Berthold Lausch

‹ [geloest] Backup and migrate Image Field Upload - automatisches Thumbnail wird nicht erzeugt ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

eigentlich ist es einfach

Eingetragen von ronald (3857)
am 26.06.2015 - 08:27 Uhr

bei Dir gehe ich davon aus, dass du GD-Lib und error-logs überprüft hast.
Aber manchesmal sind es die Selbstverständlichkeiten, die man übersieht ;-)

  • Anmelden oder Registrieren um Kommentare zu schreiben

Hallo

Eingetragen von torfnase (1525)
am 26.06.2015 - 12:47 Uhr

Hallo Roland,
selbstverständlich ist auf dem Server der GD support aktiviert.

  • Anmelden oder Registrieren um Kommentare zu schreiben

So, ich habe den

Eingetragen von torfnase (1525)
am 26.06.2015 - 13:48 Uhr

So, ich habe den vermeintlichen Fehler gefunden.
Es lag an den Verzeichnisberechtigungen, Drupal als User hatte auf diesem speziellen Server nicht die erforderlichen Berechtigungen, dort ein Thumbnail hinzuschreiben.
Normalerweise reicht ja eine Berechtigung von 755 vollkommen aus, aber in diesem Fall mußte ich ein 775 nehmen.
Dann wird das Thumbnail auch problemlos erzeugt.

Was schade ist, es gab keinerlei Fehlermeldung, oder irgendeine Nachfrage, das eine Berechtigung nicht ausreichend ist.

Gruß
Berthold Lausch

  • Anmelden oder Registrieren um Kommentare zu schreiben

auch nicht in den logs?

Eingetragen von ronald (3857)
am 26.06.2015 - 14:01 Uhr

das ist schon seltsam, da der PHP-Prozessor ja unabhängig arbeitet, und einen Fehler werfen müsste, außer er wird im Programm abgefangen, und dann verworfen, was natürlich extrem schlechter Programmierstil wäre.

  • Anmelden oder Registrieren um Kommentare zu schreiben

also ich bekomme diese fehler

Eingetragen von caw (2762)
am 27.06.2015 - 07:22 Uhr

also ich bekomme diese fehler immer bei folgenden situationen: dateiname hat leerzeichen oder sonderzeichen, datei ist ist zu gross, auflösung des bildes its zu gross (das scheint bei über 3900 pixeln mal x so anzufangen)

  • Anmelden oder Registrieren um Kommentare zu schreiben

Ich verwende immer

Eingetragen von torfnase (1525)
am 27.06.2015 - 14:12 Uhr

Ich verwende immer Transliteration.
Da hat man solche Probleme in der Regel nicht.

Gruß
Berthold Lausch

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 2 Wochen 3 Tagen
  • Vielen Dank für Ihren
    vor 2 Wochen 6 Tagen
  • Composer ist sehr ratsam
    vor 3 Wochen 23 Stunden
  • Vielen Dank für den
    vor 3 Wochen 3 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 3 Wochen 3 Tagen
  • Gut gemacht
    vor 3 Wochen 3 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 3 Wochen 3 Tagen
  • Links
    vor 3 Wochen 6 Tagen
  • Moin,wow, sehr gutes
    vor 4 Wochen 13 Stunden
  • Dass ist eine spannende
    vor 4 Wochen 20 Stunden

Statistik

Beiträge im Forum: 250316
Registrierte User: 20564

Neue User:

  • Robertspaft
  • drupalthemes
  • rofilm

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 38 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association