Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

Fehlermeldungen nach install

Eingetragen von vetegromedia (5)
am 23.09.2009 - 23:29 Uhr in
  • Allgemeines zu Drupal
  • Drupal 6.x

Das Installieren verläuft soweit gut. Wenn alles beendet ist kommen jedoch ein paar hübsche Fehlermeldungen (neueste Drupal Center Version, auf Deutsch installiert):

    * warning: array_fill() [function.array-fill]: Number of elements must be positive in /var/www/j-music/includes/database.inc on line 253.
    * warning: implode() [function.implode]: Invalid arguments passed in /var/www/j-music/includes/database.inc on line 253.
    * warning: array_keys() [function.array-keys]: The first argument should be an array in /var/www/j-music/modules/user/user.module on line 502.
    * user warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 query: SELECT p.perm FROM role r INNER JOIN permission p ON p.rid = r.rid WHERE r.rid IN () in /var/www/j-music/modules/user/user.module on line 502.

Da ich mich mit drupal nicht auskenne, weiss ich auch nicht wo ich anfangen muss zu suchen. Ich denke auch nicht, dass es etwas mit der installation ansich zu tun hat, sondern eher mit den Servereinstellungen. Ich kann alle Einstellungen vornehmen die notwendig sind (Homeserver: Debian5, MySQL5).

Vielen Dank

Michael

‹ Titelleiste enthält nur Node-Nummer [gelöst ]Text kürzen ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

Rollen

Eingetragen von stBorchert (6003)
am 24.09.2009 - 08:32 Uhr

Moin.
Es scheint so, als wären bei der Installation nicht alle erforderlichen Daten angelegt worden bzw. Daten nicht korrekt angelegt worden.
Schau mal bitte in Deine Datenbank (mit phpMyAdmin, die MySQL-Console, oder wie auch immer Du darauf zugreifst) in der Tabelle users.
Dort müssten direkt nach der Installation 2 Einträge existieren; der Erste mit uid: 0 (leerer Name) und der zweite Eintrag mit uid: 1 (Name des 1. Benutzers, den Du bei der Installation angegeben hast).

Ich vermute, dass die Ids nicht stimmen und aus diesem Grund auch kein dazugehörigeer Eintrag in den zum Nutzer gehörenden Rollen gefunden werden kann.

hth,

 Stefan

--
sei nett zu Deinem Themer

  • Anmelden oder Registrieren um Kommentare zu schreiben

Rollen

Eingetragen von vetegromedia (5)
am 24.09.2009 - 13:34 Uhr

Also in der users sind die beiden Eintäge drin. Die users_roles allerdings is leer. Und in role sind nur 2 Einträge:

1  anonymous user
2 authenticated user

  • Anmelden oder Registrieren um Kommentare zu schreiben

*PUSH*

Eingetragen von vetegromedia (5)
am 26.09.2009 - 10:03 Uhr

*PUSH*

  • Anmelden oder Registrieren um Kommentare zu schreiben

Re: Fehlermeldungen nach install

Eingetragen von traxer (1009)
am 26.09.2009 - 13:06 Uhr
vetegromedia schrieb

Die users_roles allerdings is leer. Und in role sind nur 2 Einträge:

Unmittelbar nach der Installation ist das normal.

vetegromedia schrieb

...
* warning: array_fill() [function.array-fill]: Number of elements must be positive in /var/www/j-music/includes/database.inc on line 253.
...
* warning: array_keys() [function.array-keys]: The first argument should be an array in /var/www/j-music/modules/user/user.module on line 502.

Das sind die beiden Hauptfehler. Sie haben eine gemeinsame Ursache und die anderen zwei Fehler sind Folgen davon.

Die Fehler werden durch Aufruf der Funktion user_access verursacht. Diese Funktion prüft, ob ein Benutzer eine bestimmte Berechtigung hat. Dadurch das in der Funktion ein Fehler aufgetreten ist, verfährt Drupal so als ob der Benutzer die entsprechende Berechtigung nicht hat. Es ist also nichts sicherheitskritisches passiert. Wenn die Fehler nur bei der Installation aufgetreten sind und jetzt nicht mehr erscheinen, dann würde ich sie deshalb ignorieren.

Falls du weiter untersuchen möchtest, warum der Fehler aufgetreten ist, dann füge folgendes vor der Zeile 502 in die Datei /var/www/j-music/modules/user/user.module ein:

    if (!is_array($account->roles)) {
      drupal_set_message('<pre>' . var_export(debug_backtrace(), true) . '</pre>', 'error');
      return false;
    }

und versuche, den Fehler zu reproduzieren. Dadurch solltest du sehen, wo die Funktion user_access fehlerhaft aufgerufen wird.

--
XING

  • Anmelden oder Registrieren um Kommentare zu schreiben

Nun ja, der Fehler tritt

Eingetragen von vetegromedia (5)
am 26.09.2009 - 13:42 Uhr

Nun ja, der Fehler tritt auch nach der Installation auf, wenn ich auf die index zugreifen will. Das heisst ich kann weder Die Seite sehen noch irgend etwas machen!

  • Anmelden oder Registrieren um Kommentare zu schreiben

vetegromedia schrieb Nun

Eingetragen von vetegromedia (5)
am 26.09.2009 - 20:40 Uhr
vetegromedia schrieb

Nun ja, der Fehler tritt auch nach der Installation auf, wenn ich auf die index zugreifen will. Das heisst ich kann weder Die Seite sehen noch irgend etwas machen!

Es muss definitiv ein Serverproblem sein, denn Lokal mir XAMPP läut alles einwandfrei.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Hi, ich hatte das selbe

Eingetragen von MaWoSch (24)
am 07.07.2010 - 10:59 Uhr

Hi,

ich hatte das selbe Problem.
Hab mal in die Datenbank geschaut. Da hatte der Gastuser mit dem leeren Profil die User ID 4. Habe die auf UserID 0 geändert. Jetzt klappt es.

Danke für die Hinweise.

Matthias
www.mawosch.de

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 5 Tagen 21 Stunden
  • Vielen Dank für Ihren
    vor 1 Woche 1 Tag
  • Composer ist sehr ratsam
    vor 1 Woche 3 Tagen
  • Vielen Dank für den
    vor 1 Woche 6 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 1 Woche 6 Tagen
  • Gut gemacht
    vor 1 Woche 6 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 1 Woche 6 Tagen
  • Links
    vor 2 Wochen 2 Tagen
  • Moin,wow, sehr gutes
    vor 2 Wochen 3 Tagen
  • Dass ist eine spannende
    vor 2 Wochen 3 Tagen

Statistik

Beiträge im Forum: 250316
Registrierte User: 20562

Neue User:

  • rofilm
  • Cruzorerm
  • Plandkeews

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 17 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association