Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

[gelöst]XAMPP: Apache schmiert ab, wenn mehr als 2 Seiten von Drupal gleichzeitig geladen werden

Eingetragen von tommyy (16)
am 18.05.2010 - 14:26 Uhr in
  • Allgemeines zu Drupal
  • Drupal 6.x

Moin,
ich habe hier auf einem Windows XP SP3 Rechner XAMPP (Basis Package) 1.7.3 installiert.
Wenn ich jetzt auf er lokalen Drupalinstallation mehr als 1 Seiten gleichzeitig aufrufe (bspw. 2 Seiten in Tabs im FF), dann quitiert der Apache immer mit einer Fehlermeldung:

Dies passiert nur bei Drupal. Alle anderen Scripte laufen einwandfrei.

Muss ich noch irgendwas relevantes Einstellen, oder ist der Fehler nicht zu beheben?

‹ Trotz edit any news content permission kann Benutzer einige Artikel nicht bearbeiten https nur für angemeldete Benutzer ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

Fehlerquelle unbekannt?

Eingetragen von Fleshgrinder (31)
am 18.05.2010 - 22:44 Uhr

Es handelt sich definitiv nicht um einen Drupal Fehler, da die Fehlermeldung ganz klar auf einen Segmentation Fault hinweist. Dies passiert wenn ein Prozess auf einen Speicherbereich zugreifen will, der von einem anderen Prozess gesperrt ist. Ich schätze mal, dass du XAMPP in der Standardinstallation verwendest, also mit mod_php. Du kannst folgendes ausprobieren:

  • XAMPP neu installieren
  • Andere XAMPP Version probieren
  • PHP via FastCGI einbinden
  • Lighty verwenden
  • nginx verwenden

Wo kommt eigentlich das Fenster her, also wer schmeißt die Fehlermeldung?

  • Anmelden oder Registrieren um Kommentare zu schreiben

Ok, danke für die Antwort.

Eingetragen von tommyy (16)
am 19.05.2010 - 09:29 Uhr

Ok, danke für die Antwort. Werde mal XAMPP neu installieren bzw. eine andere Version installieren. Wenn garnix mehr geht, schau ich mir mal die anderen Optionen an.
Der Fehler wird von Apache's httpd.exe ausgegeben.
In der error.log steht folgendes:

[Wed May 19 09:26:41 2010] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Wed May 19 09:26:41 2010] [notice] Digest: generating secret for digest authentication ...
[Wed May 19 09:26:41 2010] [notice] Digest: done
[Wed May 19 09:26:41 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_autoindex_color configured -- resuming normal operations
[Wed May 19 09:26:41 2010] [notice] Server built: Nov 11 2009 14:29:03
[Wed May 19 09:26:41 2010] [notice] Parent: Created child process 5188
[Wed May 19 09:26:41 2010] [notice] Digest: generating secret for digest authentication ...
[Wed May 19 09:26:41 2010] [notice] Digest: done
[Wed May 19 09:26:42 2010] [notice] Child 5188: Child process is running
[Wed May 19 09:26:42 2010] [notice] Child 5188: Acquired the start mutex.
[Wed May 19 09:26:42 2010] [notice] Child 5188: Starting 150 worker threads.
[Wed May 19 09:26:42 2010] [notice] Child 5188: Starting thread to listen on port 80.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Mit dem Statuscode vom Apache

Eingetragen von Fleshgrinder (31)
am 19.05.2010 - 09:55 Uhr

Mit dem Statuscode vom Apache findet man einiges im Internet, siehe entsprechende Google Suche. Vielleicht wirst du ja hier fündig.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Habe jetzt in der php.ini

Eingetragen von tommyy (16)
am 19.05.2010 - 15:26 Uhr

Habe jetzt in der php.ini output_buffering auf On gesetzt. Scheint alles wunderbar zu funktionieren.
Vielen Dank

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 4 Tagen 14 Stunden
  • Vielen Dank für Ihren
    vor 1 Woche 8 Stunden
  • Composer ist sehr ratsam
    vor 1 Woche 2 Tagen
  • Vielen Dank für den
    vor 1 Woche 4 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 1 Woche 5 Tagen
  • Gut gemacht
    vor 1 Woche 5 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 1 Woche 5 Tagen
  • Links
    vor 2 Wochen 20 Stunden
  • Moin,wow, sehr gutes
    vor 2 Wochen 1 Tag
  • Dass ist eine spannende
    vor 2 Wochen 2 Tagen

Statistik

Beiträge im Forum: 250316
Registrierte User: 20562

Neue User:

  • rofilm
  • Cruzorerm
  • Plandkeews

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 12 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association