Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

[gelöst] Fehlermeldung - kann jemand helfen?

Eingetragen von Ionit (1802)
am 26.05.2010 - 18:46 Uhr in
  • Allgemeines zu Drupal

Hallo,

ein Projekt welches bisher online auf einem Webserver lief, möchte ich local unter Xampp weiterentwickeln!

Ich habe alles eingerichtet und nun versucht über Backup/Migrate die Datenbank einzuspielen!

Allerdings bekomme ich jetzt einen Reihe von Fehlermeldungen - daraus werde ich aber nicht schlau!

Zitat:

Warning: MySQL server has gone away query: INSERT INTO watchdog (uid, type, message, variables, severity, link, location, referer, hostname, timestamp) VALUES (1, 'php', '%message in %file on line %line.', 'a:4:{s:6:\"%error\";s:12:\"user warning\";s:8:\"%message\";s:1666698:\"MySQL server has gone away\nquery: UPDATE cache_menu SET data = 'a:2:{s:4:\\"tree\\";a:12:{i:307;a:2:{s:4:\\"link\\";a:37:{s:14:\\"load_functions\\";N;s:16:\\"to_arg_functions\\";N;s:15:\\"access_callback\\";N;s:16:\\"access_arguments\\";N;s:13:\\"page_callback\\";N;s:14:\\"page_arguments\\";N;s:5:\\"title\\";N;s:14:\\"title_callback\\";N;s:15:\\"title_arguments\\";N;s:4:\\"type\\";N;s:11:\\"description\\";N;s:9:\\"menu_name\\& in C:\xampp\htdocs\projekt\includes\database.mysqli.inc on line 128

oder

Zitat:

Warning: MySQL server has gone away query: INSERT INTO watchdog (uid, type, message, variables, severity, link, location, referer, hostname, timestamp) VALUES (1, 'php', '%message in %file on line %line.', 'a:4:{s:6:\"%error\";s:12:\"user warning\";s:8:\"%message\";s:259:\"MySQL server has gone away\nquery: UPDATE cache_menu SET data = 'links:admin_menu:tree-data:1579203fe557df1c75e866b3681ccd7d', created = 1274891830, expire = 0, headers = '', serialized = 0 WHERE cid = 'links:admin_menu:all-cid:0'\";s:5:\"%file\";s:43:\"C:\\xampp\\htdocs\\projekt\\includes\\cache.inc\";s:5:\"%line\";i:109;}', 3, '', 'http://localhost/projekt/admin/reports/status', 'http://localhost/projekt/admin/reports/status', '127.0.0.1', 1274891830) in C:\xampp\htdocs\projekt\includes\database.mysqli.inc on line 128

Zitat:

Warning: MySQL server has gone away query: INSERT INTO watchdog (uid, type, message, variables, severity, link, location, referer, hostname, timestamp) VALUES (1, 'php', '%message in %file on line %line.', 'a:4:{s:6:\"%error\";s:12:\"user warning\";s:8:\"%message\";s:119:\"MySQL server has gone away\nquery: SELECT COUNT(sid) AS count FROM sessions WHERE timestamp >= 1274890930 AND uid = 0\";s:5:\"%file\";s:45:\"C:\\xampp\\htdocs\\projekt\\includes\\session.inc\";s:5:\"%line\";i:121;}', 3, '', 'http://localhost/projekt/admin/reports/status', 'http://localhost/projekt/admin/reports/status', '127.0.0.1', 1274891830) in C:\xampp\htdocs\projekt\includes\database.mysqli.inc on line 128

usw.

Das geht noch endlos weiter.

Auf dem WebServer wird PHP 5.2.6-1+lenny8 verwendet - unter XAMPP "PHP 5.2.6" .... SQL auf dem Webserver "5.0.51a" unter XAMPP "5.0.67"

Kann mir jemand sagen wodurch diese Fehlermeldungen eventuell ausgelöst werden - ich werde leider nicht schlau daraus!

Besten Dank schonmal

Gruß Matthias

‹ Geo Location GPS handy/mobil/iPhone und Drupal (location-modul?) - Wer weiß wie? input formats sind weg! ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

Dein mysql-Server Prozess

Eingetragen von wla (9466)
am 26.05.2010 - 19:43 Uhr

Dein mysql-Server Prozess stürzt ab beim Importieren der watchdog Einträge. Du hättest diese Tabelle allerdings vor dem Export leeren sollen (oder beim Import nur die Definition der Datenstruktur nehmen). Diese Daten haben für Deine lokale Installation absolut keine Relevanz.

Beste Grüße
Werner

  • Anmelden oder Registrieren um Kommentare zu schreiben

Hallo Werner, vielen Dank für

Eingetragen von Ionit (1802)
am 26.05.2010 - 20:08 Uhr

Hallo Werner,

vielen Dank für die Antwort. Ich bin aber leider nur SQL-Laie und ich habe bisher nur mit dem Modul "Backup & Migrate" gearbeitet - der Datenbankexport lief also nicht über PhpMyAdmin ....

Mit "leeren" meinst Du doch sicherlich, dass ich das vorher über PhpMyAdmin machen soll oder?

Danke und viele Grüße

Matthias

  • Anmelden oder Registrieren um Kommentare zu schreiben

Ja, vor dem Export mit

Eingetragen von wla (9466)
am 26.05.2010 - 20:59 Uhr

Ja, vor dem Export mit phpMyAdmin die Watchdog Tabelle leeren (und am besten alle Tabellen, die mit cache anfangen).

Beste Grüße
Werner

  • Anmelden oder Registrieren um Kommentare zu schreiben

Hmmmm ... habs genauso

Eingetragen von Ionit (1802)
am 26.05.2010 - 21:10 Uhr

Hmmmm ... habs genauso gemacht - das Backup-File war (logischerweise) ein ganzes Stück kleiner als vorher ...

Trotzdem bekomme ich beim Einspielen des Files auf der lokalen Xampp-Installation die selben Fehlermeldungen (wie oben)!

Hättest Du noch eine Idee?

  • Anmelden oder Registrieren um Kommentare zu schreiben

1) Go to xampp\mysql\bin 2)

Eingetragen von AliveAgain@drup... (59)
am 26.05.2010 - 21:35 Uhr

1) Go to xampp\mysql\bin

2) Open my.cnf

3) Change the Max packet Allowed = 64M instead of 8M (may be different) .

das sollte helfen...

Gruß
Jürgen

  • Anmelden oder Registrieren um Kommentare zu schreiben

Hallo Jürgen, das habe ich

Eingetragen von Ionit (1802)
am 26.05.2010 - 22:31 Uhr

Hallo Jürgen,

das habe ich schon vorhin versucht/Geändert - leider keine Auswirkung. Immer noch der selbe Fehler!

Habe gerade eine noch ältere Version von XAMPP aufgespielt - gleiche Fehlermeldungen!

  • Anmelden oder Registrieren um Kommentare zu schreiben

Eine ältere Version hilft da

Eingetragen von AliveAgain@drup... (59)
am 26.05.2010 - 22:45 Uhr

Eine ältere Version hilft da auch nicht. Hast du nach Änderung der INI auch den Server (Xampp) neu gestartet? Sonst wirkt sich die Änderung nämlich nicht aus.. :)

Für BackUps empfehle ich http://www.mysqldumper.net/ - solltest du mal ausprobieren.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Mit Xampp 1.7.1 läuft es

Eingetragen von Ionit (1802)
am 27.05.2010 - 00:11 Uhr

Mit Xampp 1.7.1 läuft es perfekt - der Import ging auch ohne MySqldumper tadellos.!

Vielen Dank für die Mail Jürgen ^^

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 4 Tagen 15 Stunden
  • Vielen Dank für Ihren
    vor 1 Woche 9 Stunden
  • Composer ist sehr ratsam
    vor 1 Woche 2 Tagen
  • Vielen Dank für den
    vor 1 Woche 4 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 1 Woche 5 Tagen
  • Gut gemacht
    vor 1 Woche 5 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 1 Woche 5 Tagen
  • Links
    vor 2 Wochen 21 Stunden
  • Moin,wow, sehr gutes
    vor 2 Wochen 1 Tag
  • Dass ist eine spannende
    vor 2 Wochen 2 Tagen

Statistik

Beiträge im Forum: 250316
Registrierte User: 20562

Neue User:

  • rofilm
  • Cruzorerm
  • Plandkeews

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 15 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association