Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

Datenbank / underline

Eingetragen von Anonymous (0)
am 24.10.2005 - 18:35 Uhr in
  • Allgemeines zu Drupal

Hallo zusammen :)

Habe ein Problem mit Drupal und zwar zeigt er mir folgenden Fehler an:

user error: Access denied for user: 'benutzer@localhost' to database 'usr_datenbankname_1'
query: LOCK TABLES sequences WRITE in /home/www/benutzer/html/sopor/includes/database.mysql.inc on line 66.

Nun ist meine Frage, wäre es möglich, dass Drupal mir hier rumzickt weil ich 2 underlines im Datenbanknamen habe? In der settings.php steht dazu folgendes:

* Note that the $db_url variable gets parsed using PHP's built-in
* URL parser (i.e. using the "parse_url()" function) so make sure
* not to confuse the parser. If your username, password
* or database name contain characters used to delineate
* $db_url parts, you can escape them via URI hex encodings:
*
* : = %3a / = %2f @ = %40
* + = %2b ( = %28 ) = %29
* ? = %3f = = %3d & = %26

Der Hex Code für ein underline wäre hierbei %5f, aber damit funktionierts auch nicht o.Ô

Was mach ich da falsch?

‹ Wann erscheint version 4.7 ? Installieren auf MySqL ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

hmnmm wenns drupal 4.6.3 ist

Eingetragen von micha_1977 (nicht überprüft) (0)
am 24.10.2005 - 19:01 Uhr

hmnmm

wenns drupal 4.6.3 ist dann ist das wohl eher ein anderes Problem

weil Drupal ja schon eine Query absetzen konnte, war die Verbindung zur Database schon gegeben (sonst gibts "unable to select database" oder connect errors)

MfG Micha
- work in progress mit Langmi.de

  • Anmelden oder Registrieren um Kommentare zu schreiben

hm.. an was könnte dies

Eingetragen von esteygne (nicht überprüft) (0)
am 24.10.2005 - 20:06 Uhr

hm.. an was könnte dies noch liegen?

  • Anmelden oder Registrieren um Kommentare zu schreiben

Re: Datenbank / underline

Eingetragen von Hinrich (136)
am 24.10.2005 - 20:29 Uhr
esteygne schrieb

user error: Access denied for user: 'benutzer@localhost' to database 'usr_datenbankname_1'
query: LOCK TABLES sequences WRITE in /home/www/benutzer/html/sopor/includes/database.mysql.inc on line 66.

Der Datenbank-Benutzer darf keine Tabellen sperren. Den Fehler kannst Du nur abstellen, indem Du dem Datenbank-Benutzer die entsprechenden Rechte einräumst. Auf den meisten Hostern ist das nicht möglich. Unschöner Work-A-Round: In den Einstellungen festlegen, dass Fehler nicht ausgegeben werden.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 1 Woche 3 Tagen
  • Vielen Dank für Ihren
    vor 1 Woche 6 Tagen
  • Composer ist sehr ratsam
    vor 2 Wochen 1 Tag
  • Vielen Dank für den
    vor 2 Wochen 3 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 2 Wochen 4 Tagen
  • Gut gemacht
    vor 2 Wochen 4 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 2 Wochen 4 Tagen
  • Links
    vor 2 Wochen 6 Tagen
  • Moin,wow, sehr gutes
    vor 3 Wochen 16 Stunden
  • Dass ist eine spannende
    vor 3 Wochen 23 Stunden

Statistik

Beiträge im Forum: 250316
Registrierte User: 20563

Neue User:

  • drupalthemes
  • rofilm
  • Cruzorerm

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 27 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association