Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

Daten werden nicht richtig gespeichert

Eingetragen von Fireball79 (158)
am 16.05.2014 - 14:53 Uhr in
  • Allgemeines zu Drupal
  • Drupal 7.x oder neuer

Hallo miteinander,
ich habe ein seltsames Phänomen auf einer von mir betreuten Seite.
Im Inhaltstyp Veranstaltungen sollen neue Veranstaltungen erstellt werden, mit ihren verschiednen Elementen.
Bisher klappte dies auch immer Problemlos.
Seit ein paar Tagen speichert er aber einige Elemente einer Veranstaltung nicht mehr ab.
Konkret sollen in einem Feld eine bestimmte Kategorie aus einem Veranstaltungsbereich gespeichert werden. Dieses Feld speist sich aus einem Vokabular, die Daten werden also als Referenz auf Taxonomiebegriffe abgespeichert.
Seltsam ist das es manchmal funktioniert und manchmal nicht. Allerdings kann ich nicht reproduzieren wanns klappt und wann nicht.
Cache löschen und Inhaltsberechtigungen neu aufbauen hat bislang nix geholfen. Feld löschen, entsprechenden Inhalt wieder eintragen brachte kurzzeitig Abhilfe, Phänomen ist nun aber wieder da.
Kann ja auch keine Dauerlösung sein.
Gleiches Phänomen trat zum selben Zeitpunkt mit einem anderen Feld auf.
Hat wer Ideen.
Danke schonmal

‹ 500 Internal Server Error nach Modulinstall. oder Cache-Löschen Panels - Automatisches Entfernen einer Pane sofern die Node gelöscht wurde ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

Hallo, Du solltest wenn

Eingetragen von Hyp1 (1463)
am 16.05.2014 - 15:27 Uhr

Hallo,

Du solltest wenn dieser Fehler auftritt im dblog sowie im PHP error.log nachsehen.
Da findest Du evtl. genauere Hinweise.

MfG

Robert

  • Anmelden oder Registrieren um Kommentare zu schreiben

Hallo, also im Drupal Log ist

Eingetragen von Fireball79 (158)
am 18.05.2014 - 14:58 Uhr

Hallo, also im Drupal Log ist nichts zu finden.
Bislang wurde keine php-error.log Datei erzeugt.
Hab ich nun mal gegooglet, wie dies per .htaxess aktiviert wird und dies, nach dieser Anleitung aktiviert.

Danach hab ich mal eine der Nodes bearbeitet, wieder wurde der entsprechende Wert nicht erzeugt, aber eine php-error.log-Datei wurde daraufhin nicht erstellt.

Hab ich was übersehen? Oder habt ihr weitere Tips bzw. nochmal eine Anleitung mit den richtigen Einträgen in der .htaxess-Datei, damit ich überprüfen kann, ob alles richtig ist?
Danke

  • Anmelden oder Registrieren um Kommentare zu schreiben

Hallo, es ist sehr

Eingetragen von Hyp1 (1463)
am 19.05.2014 - 09:16 Uhr

Hallo,

es ist sehr unwahrscheinlich, dass der Server keine PHP error.log
Datei hat.
Du solltest Deinen Hoster fragen wo Du diese Datei einsehen kannst.
Ich bin mir ziemlich sicher dort steht etwas über diesen Fehler drin.

MfG

Robert

  • Anmelden oder Registrieren um Kommentare zu schreiben

Also bei meinem Hoster,

Eingetragen von Fireball79 (158)
am 19.05.2014 - 15:02 Uhr

Also bei meinem Hoster, All-Inkl ist standardmäßig kein Logging aktiviert.
Das muss man per Hand in der .htaxess Datei aktivieren.

Folgende Zeilen hab ich da jetzt eingefügt:
# enable PHP error logging
php_flag log_errors on
php_value error_log ../logs/php_errors.log

Datei ist erzeugt und steht auf 777 als Dateiberechtigung.
Weiterhin wird nichts in die Datei geschrieben.
Ist da vielleicht ein Fehler in der .htaxess?

  • Anmelden oder Registrieren um Kommentare zu schreiben

Du mußt an der Stelle den

Eingetragen von wla (9466)
am 19.05.2014 - 16:26 Uhr

Du mußt an der Stelle den Datenpfad des Servers zur Logdatei eintragen. Ich vermute, daß es nicht mit einem relativen Pfad (beginnend mit ../) funktioniert. Sieh die die phpinfo an, die Du über den Link in der PHP-Zeile im Statusbericht aufrufen kannst. Dort solltest Du erkennen können, wie der genaue Pfad zu Deiner Installation auf dem Server lautet.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 1 Woche 6 Tagen
  • Vielen Dank für Ihren
    vor 2 Wochen 2 Tagen
  • Composer ist sehr ratsam
    vor 2 Wochen 4 Tagen
  • Vielen Dank für den
    vor 2 Wochen 6 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 3 Wochen 6 Stunden
  • Gut gemacht
    vor 3 Wochen 6 Stunden
  • Layout Builder etc. z.B. für Landing Pages
    vor 3 Wochen 6 Stunden
  • Links
    vor 3 Wochen 2 Tagen
  • Moin,wow, sehr gutes
    vor 3 Wochen 3 Tagen
  • Dass ist eine spannende
    vor 3 Wochen 4 Tagen

Statistik

Beiträge im Forum: 250316
Registrierte User: 20564

Neue User:

  • Robertspaft
  • drupalthemes
  • rofilm

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 15 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association