Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Module › Views ›

[gelöst] Ajax error 500 nachdem Standard Sprache auf Deutsch gestellt wurde

Eingetragen von Yunus260 (6)
am 08.06.2014 - 23:09 Uhr in
  • Views
  • Drupal 7.x oder neuer

Hi,

ich nutze Drupal 7.28.

Nachdem ich die Standard Sprache auf Deutsch gestellt habe und nun ein View bearbeiten möchte, erhalte ich die folgende Fehlermeldung:

Ein AJAX-HTTP-Fehler ist aufgetreten.
HTTP-Rückgabe-Code: 500
Im Folgenden finden Sie Debugging-Informationen.
Pfad: /?q=admin/structure/views/view/slider/preview/block/ajax
Statustext: Internal Server Error
Antworttext:
Willkommen auf ...

@import url("http://url.de/modules/system/system.base.css?n6v93r");
@import url("http://url.de/modules/system/system.menus.css?n6v93r");
und noch viele weitere @import's

Dieser Fehler taucht auch mit Englischer Sprache auf, wenn das Modul jQuery update aktiv ist (derzeit deaktiviert)

An der PHP oder Server Konfiguration sollte es also nicht liegen.

‹ Sortieren nach Starting date in Views [gelöst] Ajax error 500 nachdem Standard Sprache auf Deutsch gestellt wurde ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

Versuche mal unter

Eingetragen von Jenna (1883)
am 08.06.2014 - 23:22 Uhr

Versuche mal unter admin/config/development/jquery_update die Version bei "Alternate jQuery version for administrative pages " auf 1.5 oder 1.7 zu stellen (nur für den Admin Bereich) wenn das Modul wieder aktiviert ist.

Views hat gelegentlich Anzeigeprobleme mit einer zu hohen jQuery Einstellung im Admin Bereich. (Cache löschen nach jeder Änderung....).

Früher konnte ich nur 1.5 verwenden bei der Arbeit mit Views, jetzt geht es mit 1.7 (warum kann ich dir nicht sagen, am besten vorsichtig rantesten.)

Grüße Jenna

  • Anmelden oder Registrieren um Kommentare zu schreiben

Hi und danke für deine

Eingetragen von Yunus260 (6)
am 08.06.2014 - 23:45 Uhr

Hi und danke für deine Rückmeldung.
Ich hatte bereits testweise die Version auf 1.5 und 1.7 gesetzt, jedoch hat dies leider nichts bewirkt. Zu der Zeit hatte ich aber den Cache nicht gelöscht, was ich nun getan habe, jedoch keine Änderung.

Vielleicht noch als Hintergrundinfo:
Ich habe ein Template gekauft, bei dem schon Module dabei waren. Alle Module sind auf dem neusten Stand. (mit den Versionen die im Template waren gab es die gleiche Fehlermeldung)

Ein neuer Fehler wurde nun durch das Modul wysiwyg ausgelöst. Als ich ein hochgeladenes Bild löschen wollte, erschien wieder eine Fehlermeldung. Diesesmal etwas anders und es stand wysiwyg drin. Nachdem ich das Modul deaktiviert habe, hat das Löschen des Bildes funktioniert.

So einige Module möchten nicht so ganz.. vielleicht haben die Fehlermeldungen eine gemeinsame Ursache und es liegt nicht an jQuery oder Ajax?

Nachtrag: Falls der Fehler doch serverseitig sein sollte, ich nutze Webspace von Rackspeed und habe als Administrationsoberfläche ein cPanel. Müssen bestimmte PHP Module aktiviert sein, die standardmäßig nicht aktiv sind?

  • Anmelden oder Registrieren um Kommentare zu schreiben

Nutzt du bei dem Hoster das

Eingetragen von Jenna (1883)
am 09.06.2014 - 13:32 Uhr

Nutzt du bei dem Hoster das Paket mit 256 MB RAM oder ein kleineres Webspace-Paket?
Kannst du ein paar Daten aus der php-info bereit stellen, memory_limit, max_execution_time?

Und hast du in deinen Views momentan Ajax aktiviert oder deaktiviert (und beides getestet...)?

Grüße Jenna

  • Anmelden oder Registrieren um Kommentare zu schreiben

Hi, Ram 1

Eingetragen von Yunus260 (6)
am 09.06.2014 - 16:22 Uhr

Hi,
Ram 1 gb
memory_limit 256M
max_execution_time 900

In den Views ist Ajax deaktiviert.

Use Ajax ist immer auf No, wenn jQuery update aktiv ist, kann ich diese Einstellung und andere Einstellungen nicht verändern, da die popup boxen nicht erscheinen (anstelle derer kommt die besagte Fehlermeldung). Wenn ich erst use Ajax auf Yes stelle und anschließend jQuery update aktiviere = gleiches Problem.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Hallo, also ein 500 Server

Eingetragen von Hyp1 (1463)
am 10.06.2014 - 11:22 Uhr

Hallo,

also ein 500 Server Fehler kommt garantiert nicht von Javascript!
Dieser Fehler kommt vom Server und warum dieser Fehler auftritt
steht sicher im log des Servers (ggf /var/log/apache2/error.log).
Sieh mal dort nach einer brauchbaren Fehlermeldung.

MfG

Robert

  • Anmelden oder Registrieren um Kommentare zu schreiben

Update: Dank meinem Hoster

Eingetragen von Yunus260 (6)
am 17.06.2014 - 21:24 Uhr

Update:
Dank meinem Hoster habe ich nun die Lösung. Das aktivierte PHP Modul suhosin hat den Konflikt verursacht. Einfach deaktivieren.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 1 Woche 3 Tagen
  • Vielen Dank für Ihren
    vor 1 Woche 5 Tagen
  • Composer ist sehr ratsam
    vor 2 Wochen 19 Stunden
  • Vielen Dank für den
    vor 2 Wochen 3 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 2 Wochen 3 Tagen
  • Gut gemacht
    vor 2 Wochen 3 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 2 Wochen 3 Tagen
  • Links
    vor 2 Wochen 6 Tagen
  • Moin,wow, sehr gutes
    vor 3 Wochen 9 Stunden
  • Dass ist eine spannende
    vor 3 Wochen 17 Stunden

Statistik

Beiträge im Forum: 250316
Registrierte User: 20563

Neue User:

  • drupalthemes
  • rofilm
  • Cruzorerm

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 13 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association