Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

Schwere Probleme nach SQL-Update

Eingetragen von Knax (15)
am 09.09.2014 - 19:00 Uhr in
  • Allgemeines zu Drupal
  • Drupal 6.x oder neuer

Nach einem Serverupdate von SQL 5.1 auf 5.5 zeigt die Drupalsite keine Artikelliste und wesentliche Teile der Menüs nicht mehr an. Stattdessen erscheint auf der Startseite

"Willkommen auf Ihrer neuen Drupal-Website!

Bitte folgen Sie diesen Schritten um mit Ihrer Website zu beginnen:

..."

Die Installation lief vorher jahrelang ohne derartige Probleme. Mittlerweile zeigt nach einem Update die Statusseite auch einen aktuellen 6.33-Kern an. Bei der SQL-Version wird durchweg ein grüner Haken angezeigt. Das Problem besteht trotzdem weiter.

Auch als eingeloggter Nutzer sieht man die Inhalte nicht mehr. Als Admin eingeloggt ist jedoch alles normal, alle Artikel und Menüs werden korrekt angezeigt.

Sagt das jemandem was?

Diese Fehlermeldungen wurden ausgeworfen:

warning: preg_match() [function.preg-match]: Compilation failed: internal error: previously-checked referenced subpattern not found at offset 389 in /www/.../includes/database.inc on line 336.
user warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INNER JOIN node_access na ON na.nid = n.nid WHERE (na.grant_view >= 1 AND ((na.g' at line 1 query: SELECT COUNT(*) FROM node n WHERE n.promote = 1 AND n.status = 1 INNER JOIN node_access na ON na.nid = n.nid WHERE (na.grant_view >= 1 AND ((na.gid = 0 AND na.realm = 'all') OR (na.gid = 0 AND na.realm = 'og_public'))) in /www/.../node/node.module on line 1732.
user warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INNER JOIN node_access na ON na.nid = n.nid WHERE (na.grant_view >= 1 AND ((na.g' at line 1 query: SELECT DISTINCT(n.nid), n.sticky, n.created FROM node n WHERE n.promote = 1 AND n.status = 1 INNER JOIN node_access na ON na.nid = n.nid WHERE (na.grant_view >= 1 AND ((na.gid = 0 AND na.realm = 'all') OR (na.gid = 0 AND na.realm = 'og_public'))) ORDER BY n.sticky DESC, n.created DESC LIMIT 0, 10 in /www/.../node/node.module on line 1732.
warning: preg_match() [function.preg-match]: Compilation failed: internal error: previously-checked referenced subpattern not found at offset 389 in /www/.../includes/database.inc on line 336.
user warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INNER JOIN node_access na ON na.nid = n.nid WHERE (na.grant_view >= 1 AND ((na.g' at line 1 query: SELECT DISTINCT(n.nid) FROM node n WHERE n.status = 1 AND n.nid IN (216) INNER JOIN node_access na ON na.nid = n.nid WHERE (na.grant_view >= 1 AND ((na.gid = 0 AND na.realm = 'all') OR (na.gid = 0 AND na.realm = 'og_public'))) in /www/.../includes/menu.inc on line 988.

Und so weiter.

‹ Problem mit der Datumsangabe in Terminen Auswahl aufheben je Facet Block ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

Hmmm

Eingetragen von ronald (3857)
am 09.09.2014 - 21:55 Uhr

du hast ein altes Drupal 6 und willst es mit einer neuen Version der Datenbank, und möglicherweise PHP betreiben.
Das geht nicht immer gut.

Schau, dass du Drupal updatest, und bis dahin bitte deinen Provider, die ältere Version weiter betreiben zu dürfen.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 1 Woche 3 Tagen
  • Vielen Dank für Ihren
    vor 1 Woche 5 Tagen
  • Composer ist sehr ratsam
    vor 2 Wochen 21 Stunden
  • Vielen Dank für den
    vor 2 Wochen 3 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 2 Wochen 3 Tagen
  • Gut gemacht
    vor 2 Wochen 3 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 2 Wochen 3 Tagen
  • Links
    vor 2 Wochen 6 Tagen
  • Moin,wow, sehr gutes
    vor 3 Wochen 11 Stunden
  • Dass ist eine spannende
    vor 3 Wochen 18 Stunden

Statistik

Beiträge im Forum: 250316
Registrierte User: 20563

Neue User:

  • drupalthemes
  • rofilm
  • Cruzorerm

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 17 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association