Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

[gelöst] PDOException: SQLSTATE[22P02] PostgreSQL

Eingetragen von birddog (2)
am 13.02.2015 - 16:31 Uhr in
  • Allgemeines zu Drupal
  • Drupal 7.x

Hallo zusammen,

ich habe kürzlich meine erste Drupal-Installation unter CentOS 6.3 mit PostgreSQL 9.3 eingerichtig. Soweit funktioniert alles problemlos. Ich erhalte allerdings permament folgenden Fehler in den Logs:

PDOException: SQLSTATE[22P02]: Invalid text representation: 7 ERROR: invalid input syntax for integer: "2.1" LINE 1: ...uto label', 't', '', '', 'a:0:{}', '132', '', '', '2.1', 'si... ^: INSERT INTO menu_router (path, load_functions, to_arg_functions, access_callback, access_arguments, page_callback, page_arguments, delivery_callback, fit, number_parts, context, tab_parent, tab_root, title, title_callback, title_arguments, theme_callback, theme_arguments, type, description, position, weight, include_file) VALUES (:db_insert_placeholder_0, :db_insert_placeholder_1, :db_insert_placeholder_2, :db_insert_placeholder_3, :db_insert_placeholder_4, :db_insert_placeholder_5, :db_insert_placeholder_6, :db_insert_placeholder_7, :db_insert_placeholder_8, :db_insert_placeholder_9, :db_insert_placeholder_10, :db_insert_placeholder_11, :
...
...
...
(:db_insert_placeholder_437, :db_insert_placeholder_438, :db_insert_placeholder_439, :db_insert_placeholder_440, :db_insert_placeholder_441, :db_insert_placeholder_442, :db_insert_placeholder_443, :db_insert_placeholder_444, :db_insert_placeholder_445, :db_insert_placeholder_446, :db_insert_placeholder_447, :db_insert_placeholder_448, :db_insert_placeholder_449, :db_insert_placeholder_450, :db_insert_placeholder_451, :db_insert_placeholder_452, :db_insert_placeholder_453, :db_insert_placeholder_454, :db_insert_placeholder_455, :db_insert_placeholder_456, :db_insert_placeholder_457, :db_insert_placeholder_458, :db_insert_placeholder_459); Array ( ) in _menu_router_save() (Zeile 3837 von /var/www/homepage/includes/menu.inc).

Laut den Logs aus der Datenbank bezieht sich der fehlgeschlagene "Insert" auf eine Spalte mit dem Namen "Position". Meine Vermutung ist, dass der Befehl fehlschlägt, da "Position" unter PostgreSQL ein Schlüsselwort für eine Funktion ist und deshalb nicht als Spaltenname erkannt wird. Ich konnte diesen Fehler auf weitere Testinstallationen reproduzieren. Hat jemand eine Idee, wie ich das lösen kann? Oder liege ich da völlig falsch mit meiner Vermutung? Ich habe halt etwas sorge, dass das früher oder später Probleme bereiten könnte.

Viele Grüße

‹ Fehler: "Das Formular ist nicht mehr gültig. Speichern Sie alle..." [gelöst] PDOException: SQLSTATE[22P02] PostgreSQL ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

Das Problem hat sich

Eingetragen von birddog (2)
am 18.02.2015 - 09:51 Uhr

Das Problem hat sich erledigt. Der Fehler wurde durch das Modul "Automatic Entity Label" verursacht. Da ich auf das Modul verzichten kann, habe ich es deaktiviert.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 1 Woche 5 Tagen
  • Vielen Dank für Ihren
    vor 2 Wochen 1 Tag
  • Composer ist sehr ratsam
    vor 2 Wochen 3 Tagen
  • Vielen Dank für den
    vor 2 Wochen 5 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 2 Wochen 6 Tagen
  • Gut gemacht
    vor 2 Wochen 6 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 2 Wochen 6 Tagen
  • Links
    vor 3 Wochen 1 Tag
  • Moin,wow, sehr gutes
    vor 3 Wochen 2 Tagen
  • Dass ist eine spannende
    vor 3 Wochen 3 Tagen

Statistik

Beiträge im Forum: 250316
Registrierte User: 20564

Neue User:

  • Robertspaft
  • drupalthemes
  • rofilm

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 49 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association