Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

[gelöst] Drupal Fehler nach Update:

Eingetragen von ergy1983 (3)
am 02.07.2015 - 15:40 Uhr in
  • Allgemeines zu Drupal
  • Drupal 7.x oder neuer

Hallo,

ich bin verzweifelt. Ich habe ein paar Aktualisierungen durchgeführt und nun bekomme ich immer folgende Fehlermeldung auf der Frontpage:

"Fatal error: Cannot redeclare corporate_html_head_alter() (previously declared in /home/ld/pp/sites/all/themes/corporate/template.php:6) in /home/ld/pp/sites/all/themes/ld/template.php on line 10"

Bei den Aktualiserungen gabe es eine Fehlermeldung für Drupalchat, dass der Ordner ../sites/all/modules/drupalchat nicht gelöscht werden konnte und

The following updates returned messages
redirect module
Update #7102

1 circular redirect causing infinite loop was disabled.

Kann mir jemand helfen? Ich weiß nicht, was ich tun soll...

Danke,
Sandra

‹ [gelöst] User account: Felder hinzufuegen [gelöst] Drupal Fehler nach Update: ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

1. Problem:"Fatal error:

Eingetragen von montviso (2189)
am 02.07.2015 - 16:45 Uhr

1. Problem:
"Fatal error: Cannot redeclare corporate_html_head_alter() (previously declared in /home/ld/pp/sites/all/themes/corporate/template.php:6) in /home/ld/pp/sites/all/themes/ld/template.php on line 10"

Das heißt, daß eine Funktion zweimal vorkommt.
Ich lese das so, daß es ein Theme ld gibt, welches ein Subtheme von corporate ist und in beiden ist die Funktion corporate_html_head_alter() in der Datei template.php eingebaut.

Dem Namen nach hat sie aber nur im Theme corporate was zu suchen und im Subtheme sollten nur eigene Funktionen mit Namen des Subthemes stehen.

2. Problem
Wenn ein Ordner nicht gelöscht werden kann, könnte das ein Rechteproblem sein.
Ich kenne das Modul aber nicht und kann nicht mehr dazu sagen.

3. Redirect Module:
Da hast Du eine Weiterleitung eingabaut im Stil von Seite A leitet auf Seite B und Seite B leitet auf Seite A.
Das gibt dann eine Endlos-Schleife (loop).

Wie das zustande kommt, wenn Du nur ein Update machst und sonst nichts geändert hast, kann ich allerdings auch nicht sagen.
Evt. ist das Problem weg, wenn Du die Update.php noch mal laufen läßt.

Hilfreich ist bei solchen unklaren Fehlern auch ein Einblick in das Access bzw. ins Error Log vom Webserver.
Da könntest Du evt. sehen, welche Seite aufgerufen wird, wenn es zur Endlosschleife kommt.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Vielen, vielen Dank

Eingetragen von ergy1983 (3)
am 03.07.2015 - 09:07 Uhr

Vielen, vielen Dank Montviso,

kannst du mir vielleicht auch sagen, ob ich dann in der template.php einfach etwas löschen muss? oder woanders? und wenn dann was?...

  • Anmelden oder Registrieren um Kommentare zu schreiben

ok, hab's gelöst. Hab jetzt

Eingetragen von ergy1983 (3)
am 03.07.2015 - 09:31 Uhr

ok, hab's gelöst. Hab jetzt einfach alle Funktionen aus der "ld"-template.php rasugelöscht, die in der "corporate"-template.php bereits drin waren...

Nun funktioniert wieder alles...
Und das zweite Mal Update laufen lassen hat auch die Loop gelöst...

Danke

  • Anmelden oder Registrieren um Kommentare zu schreiben

Ja super...da waren die

Eingetragen von montviso (2189)
am 03.07.2015 - 10:08 Uhr

Ja super...da waren die anderen Fehler evt. Folgefehler.
Dann kannst Du ja oben in der Betreffzeile noch ein [gelöst] davor schreiben.
Gruß, Regina

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 2 Wochen 3 Tagen
  • Vielen Dank für Ihren
    vor 2 Wochen 6 Tagen
  • Composer ist sehr ratsam
    vor 3 Wochen 23 Stunden
  • Vielen Dank für den
    vor 3 Wochen 3 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 3 Wochen 3 Tagen
  • Gut gemacht
    vor 3 Wochen 3 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 3 Wochen 3 Tagen
  • Links
    vor 3 Wochen 6 Tagen
  • Moin,wow, sehr gutes
    vor 4 Wochen 13 Stunden
  • Dass ist eine spannende
    vor 4 Wochen 20 Stunden

Statistik

Beiträge im Forum: 250316
Registrierte User: 20564

Neue User:

  • Robertspaft
  • drupalthemes
  • rofilm

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 39 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association