Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

[gelöst] Fehler nach Update

Eingetragen von simpsonetti (80)
am 23.07.2015 - 16:34 Uhr in
  • Allgemeines zu Drupal
  • Drupal 7.x oder neuer

Hallo,
wir haben eine Drupalseite bei unerem Hoster.
Ich habe updates bisher immer lokal gemacht, da hier mehr ressourcen bzgl RAM und CPU vorhanden sind.
Also habe ich den kompletten Drupalordner heruntergeladen, sowie die DB exportiert.
Dieses beides habe ich hier im LAN verfügbar gemacht und die Seite lief auch.
Im Anschluss habe ich das update gemacht und auch danach war alles gut.
Dann habe ich den Ordner hochgeladen und beim importieren der DB hatte er zuerst gemeckert. Dies lag an der Laufzeit von PHP.
ich habe dann den Mysqldumper genutzt und der lief dann durch (mit der Einstellung Fehler nur zu loggen, wobei ich die Fehelr nicht sehen konnte).
Nun sagt mir aber unsere Seite folgenden Fehler:
Fatal error: Call to undefined function views_get_all_views() in /www/htdocs/XXXXXXXXXXX/sis/sites/all/modules/themekey/modules/themekey.views.inc on line 143

Kann mir jemand sagen, wie ich das beheben kann?

Gruß Sebastian

‹ [gelöst] Suche Empfehlung für Drupal Hosting in der Schweiz [gelöst] Fehler nach Update ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

Ehrlich gesagt kann ich dir

Eingetragen von Goekmen (1013)
am 23.07.2015 - 22:18 Uhr

Ehrlich gesagt kann ich dir nicht helfen, aber deine Vorgehensweise scheint in meinen Augen nicht optimal zu sein und auch nicht der Drupalweg.
An deiner Stelle würde ich die Website Online spiegeln und dort die Updates machen und wenn alles in Ordnung ist auf der Produktivseite.
Die Datenbank kann man gut mit Backup & Migrate importieren/exportieren (falls du diese Funktion benötigst).

  • Anmelden oder Registrieren um Kommentare zu schreiben

Der Fehler deutet darauf hin

Eingetragen von ronald (3857)
am 23.07.2015 - 22:26 Uhr

dass irgendetwas nicht komplett übertragen wurde.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Okay, ich habe das ganze noch

Eingetragen von simpsonetti (80)
am 24.07.2015 - 08:43 Uhr

Okay, ich habe das ganze noch mal mit rsync übertragen, falls etwas beim Übertragen schief gegangen sein sollte. bisher gibts keine Besserung.
Mir ist aber eben im Mysqldumper aufgefallen, das es da Fehler beim importieren gab.
Und zwar stehen da im error.log Einträge mir "Duplicate entry". Dieses aber wohl in verschiedenen Tabellen, wovon manche aber auch als Modul nicht aktiviert sind.

Sollte ich die DB noch mal löschen und dann wieder importieren?

  • Anmelden oder Registrieren um Kommentare zu schreiben

Es läuft wieder. Da es so

Eingetragen von simpsonetti (80)
am 27.07.2015 - 07:59 Uhr

Es läuft wieder.
Da es so "trivial" ist, habe ich echt überlegt das hier noch zu lösen aber es geht ggf anderen auch so.

Meine vorgehensweise ist im Grunde in Ordnung. Jedoch ist ein Punkt, und zwar der Letzte nicht ovn mir bedacht worden, oder ggf habe ich es von den letzen malen einfach nur vergessen: Der Eigentümer und ggf die Besitzrechte müssen noch mal angepasst werden. Just als ich das gemacht habe lief es gleich.

Ich danke allen mithelfenden hier.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 1 Woche 5 Tagen
  • Vielen Dank für Ihren
    vor 2 Wochen 1 Tag
  • Composer ist sehr ratsam
    vor 2 Wochen 3 Tagen
  • Vielen Dank für den
    vor 2 Wochen 5 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 2 Wochen 6 Tagen
  • Gut gemacht
    vor 2 Wochen 6 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 2 Wochen 6 Tagen
  • Links
    vor 3 Wochen 1 Tag
  • Moin,wow, sehr gutes
    vor 3 Wochen 2 Tagen
  • Dass ist eine spannende
    vor 3 Wochen 3 Tagen

Statistik

Beiträge im Forum: 250316
Registrierte User: 20564

Neue User:

  • Robertspaft
  • drupalthemes
  • rofilm

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 49 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association