Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

Drupal 8 mit SQlite Installation klappt nicht

Eingetragen von softart (13)
am 01.12.2015 - 16:07 Uhr in
  • Allgemeines zu Drupal
  • Drupal 8.x

Ich habe drupal-8.0.0 (am 30.11.2015) runtergeladen, auf meinem Windows-PC installiert, via localhost hat alles funktioniert inkl. Erstellen einer minimalen Seite (im Verzeichnis drupal-8.0.0_myNewSite). Als DB habe ich SQlite gewählt, da ich nach diesem lokalen Test Drupal auf meinem Webspace bei einem Cloud-Provider installieren wollte, dort ist für mich nur php (v5.5.30) vorhanden, nicht mysql.
Nach Upload eines (frisch heruntergeladenen ) drupal-8.0.0 Verzeichnisbaums rufe ich via Webbrowser die install.php auf, sie läuft fast durch, aber kurz vor Schluss meldet die Installtionsroutine einen "out-of-memory" Error, was offenbar öfter mal vorkommt (ich habe andere Forumseinträge gelesen):
Fatal error: Out of memory (allocated 32505856) (tried to allocate 7168 bytes) in /core/modules/views/src/Plugin/views/filter/InOperator.php on line 202

Da ich (gemäss Tipps in Forumseinträgen) in "sites/default/settings.php" keine Einstellungsmöglichkeit gefunden habe, habe ich Plan B versucht: laut Forumseinträgen soll es ja möglich sein, fertige Installationen per Kopie auf einen Server zu übertragen (und auszuführen). Also habe ich den Verzeichnisbaum drupal-8.0.0_myNewSite (s.o.) auf den Host-Server kopiert, die Startseite lässt sich auch aufrufen, aber sie erscheint ohne Layout: s. Grafik, links die Version auf meinem Desktop (via localhost), rechts die via Internet aufgerufene Version.

Trotz mehrfacher Versuche immer das gleiche Ergebnis. Kann man fertige Drupal-Installationen doch nicht 1:1 auf anderen Server übertragen? Evtl. wg. Binärformats der .ht.sqlite Datei? Oder hat jemand eine gute Idee die ggf. weiterhilft?

AnhangGröße
drupal-Installations-Fehler_screenshot.jpg64.42 KB
‹ Link zum Kontaktformular des Authors Drupal 8 mit SQlite Installation klappt nicht ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

Für Drupal 8 wird allein für

Eingetragen von fromfriends (24)
am 01.12.2015 - 21:12 Uhr

Für Drupal 8 wird allein für den Core ein Memory-Limit von 64MB empfohlen (vgl: https://www.drupal.org/requirements/php) Da läst Dich Dein 1&1-Hosting schon im Stich (daher auch der "out-of-memory"-Fehler) ...

Die DB von Deiner lokalen Installation hast Du auch auf den Server überspielt?

  • Anmelden oder Registrieren um Kommentare zu schreiben

Du solltest dir unbedingt ein Tarifupgrade gönnen.

Eingetragen von ronald (3857)
am 01.12.2015 - 22:30 Uhr

Dann hast du auch eine mySQL-Datenbank und ein anständiges Hostingpakte mit mindestens 128 MB RAM
Drunter macht es wenig Freude.

Bei einem Massenhoster mit dem billigsten Paket wirst du mit einem professionellen CMS nichts anfangen können.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Memory Limit sollte ausreichend sein

Eingetragen von softart (13)
am 02.12.2015 - 14:20 Uhr

ein phpinfo() liefert im Abschnitt "Core": memory_limit 120M. Ich nehme an, das soll 120 MB bedeuten, also wesentlich mehr als die von Drupal8 geforderten 64MB. Daran sollte es nicht liegen. Und: ja, ich habe die SQlite-Datei mit hochgeladen.
Es sollte also an diesen beiden Dingen nicht liegen, oder?

  • Anmelden oder Registrieren um Kommentare zu schreiben

Zitat: Fatal error: Out of

Eingetragen von wla (9466)
am 02.12.2015 - 15:31 Uhr
Zitat:

Fatal error: Out of memory (allocated 32505856) (tried to allocate 7168 bytes)

Das bedeutet, Deine Installation hat genau 32MB zur Verfügung und keine 120MB. Vielleicht solltest Du mal mit dem Support des Hosters reden, wie es zu dieser Diskrepanz kommt. Evtl. bekommst Du die 120MB nur, wenn es nicht mit anderen kollidiert und das ist keine ausreichende Basis für Deine Drupal Installation. Btw.: Selbst bei Drupal 7 habe ich keine Installation angefangen, wenn ich nicht 128MB beim Hoster zur Verfügung hatte und selbst das hat in speziellen Fällen nicht gereicht.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Das ist dann ein Thema für den Hostingsupport

Eingetragen von ronald (3857)
am 02.12.2015 - 16:39 Uhr

Die Fehlermeldung sagt klar:

Zitat:

ich habe 32 MB allokiert, und der Versuch weitere 7 KB zu allokieren wurde vom Betriebssystem verweigert.

Wenn dir laut config 120 MB zustünden, ist dies ein Problem des Hosters, wenn er sie dir im Bedarfsfall nicht zur Verfügung stellen kann.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Problem gelöst

Eingetragen von softart (13)
am 08.12.2015 - 23:07 Uhr

Hallo,
vielen Dank für eure Antworten, hat mir sehr geholfen.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 1 Woche 3 Tagen
  • Vielen Dank für Ihren
    vor 1 Woche 5 Tagen
  • Composer ist sehr ratsam
    vor 2 Wochen 20 Stunden
  • Vielen Dank für den
    vor 2 Wochen 3 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 2 Wochen 3 Tagen
  • Gut gemacht
    vor 2 Wochen 3 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 2 Wochen 3 Tagen
  • Links
    vor 2 Wochen 6 Tagen
  • Moin,wow, sehr gutes
    vor 3 Wochen 10 Stunden
  • Dass ist eine spannende
    vor 3 Wochen 18 Stunden

Statistik

Beiträge im Forum: 250316
Registrierte User: 20563

Neue User:

  • drupalthemes
  • rofilm
  • Cruzorerm

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 13 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association