Startseite
  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche
Startseite › Forum › Drupalcenter.de › Allgemeines zu Drupal ›

Anzeige Fehler im Themebereich

Eingetragen von shibuyacity (18)
am 03.12.2007 - 11:18 Uhr in
  • Allgemeines zu Drupal
  • Drupal 5.x oder neuer

Hallo,
ich habe frisch Drupal 5.3 installiert. Hat soweit auch alles gut funktioniert.
Allerdings bekomme ich noch bevor ich überhaupt irgendetwas an meinem Drupal anpasse an einigen Stellen Fehler ausgegeben, die ich nicht im Stande bin zu beheben.

Unter Verwaltung - Themes bekomme ich folgendes angezeigt, wenn ich einen Theme modifizieren möchte:

warning: fopen(files/.htaccess): failed to open stream: Permission denied in /www/htdocs/w00944c5/includes/file.inc on line 117.
Sicherheitswarnung: .htaccess-Datei konnte nicht geschrieben werden. Bitte erstellen sie eine .htaccess-Datei im files-Verzeichnis, mit folgendem Inhalt:
SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006
Options None
Options +FollowSymLinks

Ich bin leider noch blutiger Anfänger, was den Umgang mit Php betrifft und wäre daher um kleine Starthilfen sehr dankbar.
Die .htaccess-Datei habe ich versucht zu erstellen, im verlangten Verzeichnis. Jedoch ändert sich danach auch nichts an der Fehleranzeige. Was mache ich falsch?

Grüße

‹ Wie Registrierungsformular themen/als Block? Benutzeranmeldung - weisse Seite ›
  • Anmelden oder Registrieren um Kommentare zu schreiben

.htaccess-Dateien sind

Eingetragen von quiptime (4972)
am 03.12.2007 - 12:18 Uhr

.htaccess-Dateien sind sogenannte unsichtbare Dateien. Je nach dem welches FTP-Programm Du zum Upload von Drupal verwendet hast und wie dieses bezueglich der Anzeige unsichtbarer Dateien eingestellt ist kann es sein, das die existierende .htaccess-Datei von Drupal nicht mit hochgeladen wurde.
Also Du musst erst mal keine neue .htaccess-Datei erstellen sondern nur die vorhandene aendern und hochladen.

Schau mal in Deinem FTP-Programm wie es bezueglich unsichtbarer Dateien konfiguriert ist.

Hier ein Ausschnitt aus einer Drupal 5.3 .htaccess:

#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "\.(engine|inc|info|install|module|profile|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(code-style\.pl|Entries.*|Repository|Root|Tag|Template)$">
  Order allow,deny
</FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Customized error messages.
ErrorDocument 404 /index.php

# Set the default handler.
DirectoryIndex index.php

Options +FollowSymLinks ist schon gesetzt. Fehlt also noch

SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006
Options None

-------------
quiptime

Nur tote Fische schwimmen mit dem Strom.

XING

  • Anmelden oder Registrieren um Kommentare zu schreiben

Herzlichen Dank! Es klappt

Eingetragen von shibuyacity (18)
am 03.12.2007 - 12:58 Uhr

Herzlichen Dank! Es klappt nun alles wunderbar.

  • Anmelden oder Registrieren um Kommentare zu schreiben

Benutzeranmeldung

  • Registrieren
  • Neues Passwort anfordern

Aktive Forenthemen

  • Canvas Palette: Eine fertige Komponentenbibliothek für Drupal Canvas
  • Hilfe zu Updates oder Composer
  • Vergleich Drupal und Contao
  • [geloest] Blocks in Bootstrap nebeneinander darstellen und nicht untereinander
  • DrupalCamp Frankfurt 27-28 November 2026
  • Bitte mein Bentzerkonto löschen
  • Beim Aufruf einiger Inhalte erhalte ich folgende Fehlermeldung
  • Neuinstallation: vermutlich ein rewrite-Problem
  • Drupal CMS installieren
  • [erledigt]MP3 in Drupal 10 einbinden
  • (gelöst)Drupal 11 installieren
  • Titel ausblenden
Weiter

Neue Kommentare

  • Danke ich werde mir die
    vor 3 Tagen 18 Stunden
  • Vielen Dank für Ihren
    vor 6 Tagen 12 Stunden
  • Composer ist sehr ratsam
    vor 1 Woche 1 Tag
  • Vielen Dank für den
    vor 1 Woche 3 Tagen
  • Die alten CMS Vergleiche von contentmanager.de
    vor 1 Woche 4 Tagen
  • Gut gemacht
    vor 1 Woche 4 Tagen
  • Layout Builder etc. z.B. für Landing Pages
    vor 1 Woche 4 Tagen
  • Links
    vor 2 Wochen 59 Minuten
  • Moin,wow, sehr gutes
    vor 2 Wochen 1 Tag
  • Dass ist eine spannende
    vor 2 Wochen 1 Tag

Statistik

Beiträge im Forum: 250316
Registrierte User: 20562

Neue User:

  • rofilm
  • Cruzorerm
  • Plandkeews

» Alle User anzeigen

User nach Punkten sortiert:
wla9466
stBorchert6003
quiptime4972
Tobias Bähr4019
bv3924
ronald3857
md3717
Thoor3678
Alexander Langer3416
Exterior2903
» User nach Punkten
Zur Zeit sind 0 User und 7 Gäste online.

Hauptmenü

  • » Home
  • » Handbuch & FAQ
  • » Forum
  • » Übersetzungsserver
  • » Suche

Quicklinks I

  • Infos
  • Drupal Showcase
  • Installation
  • Update
  • Forum
  • Team
  • Verhaltensregeln

Quicklinks II

  • Drupal Jobs
  • FAQ
  • Drupal-Kochbuch
  • Best Practice - Drupal Sites - Guidelines
  • Drupal How To's

Quicklinks III

  • Tipps & Tricks
  • Drupal Theme System
  • Theme Handbuch
  • Leitfaden zur Entwicklung von Modulen

RSS & Twitter

  • Drupal Planet deutsch
  • RSS Feed News
  • RSS Feed Planet
  • Twitter Drupalcenter
Drupalcenter Team | Impressum & Datenschutz | Kontakt
Angetrieben von Drupal | Drupal is a registered trademark of Dries Buytaert.
Drupal Initiative - Drupal Association